The pfSense development team is proud to bring you the 1.2 release! This brings the features and bug fixes from more than 16 months of development since the 1.0 release. Already widely tested and deployed throughout the Release Candidate phase, this release provides the finishing touches on releases already proven in a wide range of network environments. The Release Candidate versions have been downloaded more than 250,000 times.

The changes since the RC4 release follow.

  • Improve CARP input validation - GUI previously allowed incorrect configurations that caused panics. Fixed to not allow entry of such configurations, so typos and configuration errors cannot crash system.
  • Clarify text and fix typos on several screens.
  • Revert DHCP client to default timeout of 60 seconds.
  • Reload static routes when an interface IP address is changed by an administrator.
  • Fix a few areas allowing potential cross site scripting.
  • Fix a couple issues with package uninstalls.
  • Shorten firewall rule, NAT and traffic shaper description fields to prevent users from entering description names too long for the pf ruleset.
  • Fix traffic shaper queue name generation to prevent creating invalid ruleset for interface names longer than 15 characters.
  • Improve efficiency of RRD graph creation by removing duplicate commands. Graph updates now use less CPU time.

For a complete list of all source commits since the branching of the 1.2 release, see the cvstrac change log.

Upgrade Information

For those wishing to upgrade to the 1.2 release from any previous pfSense release, please see the Upgrade Guide.

New to the pfSense Project?

For those new to the project, we recommend checking out our Features page and screenshot gallery.

If you’re ready to install, a user contributed installation guide is available.

Downloads

It will be as long as 24 hours before all the mirrors have the 1.2 release, but it is currently available on some of them including the NYI.net mirror.

Note if you aren’t sure which version you need, see the Versions page on the website.

New installs
Updates

Support for previous versions

1.2 is the only supported pfSense version. No previous releases will receive any bug fix updates nor any future security updates. 1.2 is significantly more stable than past release versions, and we strongly recommend everyone make plans to upgrade. There are systems out there with several years of uptime running very early alpha pfSense releases that are stable, but we advise against that.

Share this post