Technical Paper

Why Choose 64-bit for pfSense?

3 Reasons to Upgrade Your Firewall

In 2017, Netgate announced that pfSense software 2.4 would deprecate support for 32-bit Intel/AMD hardware and NanoBSD Installations. Version 2.3.5 still supports 32-bit Intel/AMD and NanoBSD, and that version has been maintained for a year after the release of 2.4, to include security fixes. The 2.3 series of pfSense software, along with FreeBSD 10, upon which is based, will both End-of-Life at the end of October 2018.

If you read no further, please leave with this thought: If your firewall platform is based on 32-bit Intel or AMD hardware, it is time to upgrade.

Get the Technical Paper Here

Download Now

More Resources: